Apache, PHP, Oracle and Windows

Modérateur: musique

Apache, PHP, Oracle and Windows

Messagepar jesuslewis » Mer Août 09, 2017 8:50 am

Hello,

So I had a failure on an ancient Sun UltraSPARC server which was hosting an old PHP app. The server experienced some core software failure, and for various reasons, it is being abandoned.

But we still have this old, poorly coded internal PHP app that needs to be hosted. It has some specific requirements, which have limited our choices rather severely. Basically, the app won't work with any PHP interpreter newer than 5.3. It really is a badly coded app, and it's being replaced next year, but in the meantime, I have to get it running.

After going through our options, we decided to set it up on a Windows server. So I have this box (running Windows 7 Pro) onto which I have installed PHP 5.3.29, Apache httpd 2.2.225, OpenSSL 0.9.8y, Oracle Instant Client 12.1.0.2.0, and the PECL OCI8 library for Oracle 12c and PHP 5.2+ (php_oci8_12c.dll), php-oci8-2.0.12.5-3-nts.


I didn't find the right solution from the internet.
References:
https://hardforum.com/threads/how-can-i ... y.1920746/
Energy Efficiency Video Examples
jesuslewis
 
Messages: 96
Inscrit le: Jeu Juil 06, 2017 2:33 pm

Retour vers TKO-france

cron